
NODEXL PRO TUTORIAL :
MAPPING POLITICAL NETWORKS

WITH TWITTER USER NETWORK DATA



ABOUT THIS TUTORIAL
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This NodeXL Pro Tutorial is associated with the 
Research Project: Mapping Political Networks 
initiated by the Social Media Research Foundation.

In a series of studies we will explore Twitter networks 
based on Tweets published by politicians in regional, 
national and international parliaments. 

This tutorial is based on a case study with 512 Twitter 
accounts from the German Bundestag. The presented 
method can be adapted easily to analyze any other 
parliament.

All related network maps can be found in NodeXL
Graph Gallery under #nxlBundestag.

Tutorial requirements:

▪ Windows Excel

▪ NodeXL Pro User license

▪ Twitter account

Necessary background information:

How to automate NodeXL Pro (Video Tutorial): 
https://www.youtube.com/watch?v=mjAq8eA7uOM

More information on NodeXL:

https://www.smrfoundation.org

Find NodeXL Pro network reports and maps:

https://nodexlgraphgallery.org

https://nodexlgraphgallery.org/Pages/Default.aspx?search=#nxlBundestag
https://www.youtube.com/watch?v=mjAq8eA7uOM
https://www.smrfoundation.org/
https://nodexlgraphgallery.org/
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1. POLITICAL NETWORK MAPS

Party Network Map

Grouping the politicians by party affiliation allows a focused analysis of 
each party, resulting in a network map with one group for each party.
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Full Network Map

This network map is the result of a full social network and content analysis 
summarizing recent tweets from all politicians in a parliament.

Coalition Network Map

When politicians are algorithmically clustered into groups, and then colored by 
party affiliation, the resulting network map may show current Twitter coalitions.

Party Interaction Map

Derived from the party network dataset, this network 
map shows interactions between the parties.



2. THE SEED LIST

1. Find a list on Twitter: Many news agencies have Twitter lists that are 
available for download via the NodeXL Pro Twitter Users Network 
Importer (e.g.: https://twitter.com/cspan/lists/senators )

Note: Usually there is no information on when such a list was created or 
last updated, therefore we recommend you to create your own list.

2. Create your own seed list: Start your own table with the name of the 
politician, the respective Twitter handle and the party affiliation (see on 
the right).
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Starting point of any analysis with the NodeXL Pro Twitter Users Network importer is a list of Twitter 
handles we refer to as the seed list. Creating such a list is probably the most time-consuming step of all.

https://twitter.com/cspan/lists/senators


3. DATA IMPORT OPTIONS
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Full network data (box unchecked)

Edge data includes edges to all Twitter users 
mentioned in tweets by users in seed list.

e.g. Users in seed list: 512

Vertices in network: 2,976

Internal network data (box checked)

This is a subset of the full network dataset. Edge data 
contains only edges between users in the seed list.

e.g. Users in seed list: 512

Vertices in network: 512

All data will be collected with the NodeXL Pro Twitter Users Network Importer.

The maximum number of available Tweets per user is 3,200.

Checking or unchecking the box Import only the Twitter users I‘m interested in 
will result in two different datasets that are based on the same tweets:



4. FULL NETWORK MAP
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Workflow

Step 1: Import data

Step 2: Prepare data

Step 3: Automate

https://nodexlgraphgallery.org/Pages/Graph.aspx?graphID=167637

https://nodexlgraphgallery.org/Pages/Graph.aspx?graphID=167637


4. FULL NETWORK MAP – IMPORT DATA
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1. Open a new NodeXL file and save it to your machine 
(e.g. MdB External Network 2018-09-12 raw data).

2. Make sure automation after data import is turned off 
(Data > Import > Import Options).

3. Open Data > Import > Import from Twitter Users 
network.

4. Enter the Twitter handles from your seed list into the 
search field.

5. Choose the importer setup on the right. Make sure to 
limit the number of tweets to 100. 

6. Click OK and wait. Downloading 100 tweets from 500 
users each will take about 3 hours.

7. Save the file after the download is finished.



4. FULL NETWORK MAP – PREPARE DATA
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In order to analyze the most recent Twitter discussions, you should remove 
old tweets from the dataset. The past 7 to 10 days before the date of your 
data collection is a reasonable time frame in relation to the maximum 
number of 100 collected Tweets per user.

1. Save the raw data file to a new file and add your time frame to the file name: 
e.g. MdB External Network 2018-09-12 since 2018-09-03

2. Sort the edges spreadsheet by Column P (Relationship Date (UTC)).

3. Click Show/Hide > Workbook Columns > Visual Properties

4. In Column G (Visibility) copy and paste Skip into all rows you want to exclude 
from the analysis. Alternatively, you can delete these edges from the dataset 
for better data handling, but this is usually not recommended.



4. FULL NETWORK MAP – AUTOMATE
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The automation file used for this analysis can be downloaded in the NodeXL Graph Gallery at the bottom of this page: 
https://nodexlgraphgallery.org/Pages/Graph.aspx?graphID=167637

1. To import the automation file into NodeXL go to 
Options > Import and choose the options file you 
have just downloaded.

2. Click on Graph > Automate to open the Automate 
window.

3. Click Run and wait. Processing 10,000 tweets may 
take a few hours depending on RAM and CPU of 
your machine.

4. The resulting network map will be saved to the 
Excel file in PNG format as part of the automation 
process. You can specify image options with a 
right-click in the graph window and select Save 
Image to File > Image options.

https://nodexlgraphgallery.org/Pages/Graph.aspx?graphID=167637


5. COALITION NETWORK MAP

11https://nodexlgraphgallery.org/Pages/Graph.aspx?graphID=167559

Workflow

Step 1: Import data

Step 2: Prepare data

Step 3: Automate

Step 4: Color Vertices

https://nodexlgraphgallery.org/Pages/Graph.aspx?graphID=167559


5. COALITION NETWORK MAP – IMPORT DATA
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1. Open a new NodeXL file and save it to your machine 
(e.g. MdB Internal Network 2018-09-12 raw data)

2. Choose the importer setup on the right. Make sure 
to check the box: Import only the Twitter users I‘m 
interested in.

3. After data download, save the file and then set the 
time frame to prepare the data for automation.



5. COALITION NETWORK MAP – AUTOMATE
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1. Import the options file above, Automate and wait for 
automation to finish. Note: Do not use the „Find and 
import missing tweets“ feature because it will add new 
vertices to the dataset.

2. The vertex colors in the resulting network map are 
currently set in the Groups spreadsheet based on the 
detected clusters (see on the right).

3. In the next step we will set the vertex colors to align with 
the party affiliation.

The automation file used for this analysis can be found in the NodeXL Graph Gallery at the bottom of this page: 
https://nodexlgraphgallery.org/Pages/Graph.aspx?graphID=167535

https://nodexlgraphgallery.org/Pages/Graph.aspx?graphID=167535
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1. Create a New Sheet in the workbook (here Sheet 8).

2. Copy and paste Twitter handles and party affiliation from your seed 
list into the new spreadsheet.

3. Sort Twitter handles from A to Z. 

4. In the vertices worksheet sort column A (Vertex) from A zo Z.

5. Go to column AC and name it e.g. Party.

6. Fill in the formula into cell AC 3: 
=VLOOKUP([@Vertex],Table24[#All],2) to link to the Twitter handles in 
the newly created worksheet.

7. Sort worksheet by column AC (Party).

8. Copy and paste party colors into each row of column B (Color) in 
relation to column AC (Party)

9. Open Analysis > Groups > Group options and check the box „Colors 
specified in the Color column of the Vertices worksheet“.

10. Open Graph Options > Vertices and set Shape from Image to Disk.

11. Refresh Graph.

5. COALITION NETWORK MAP – COLOR VERTICES
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1. Create a New Sheet in the workbook (here Sheet 8).

2. Copy and paste Twitter handles and party affiliation from your seed 
list into the new spreadsheet.

3. Sort Twitter handles from A to Z. 



16

6

4 5
6

4. In the vertices worksheet sort column A (Vertex) from A zo Z.

5. Go to column AC and name it e.g. Party.

6. Fill in the formula into cell AC 3: =VLOOKUP([@Vertex],Table24[#All],2) 
to link to the Twitter handles in the newly created worksheet.
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7. Sort worksheet by column AC (Party).

8. Copy and paste party colors into each row of column B (Color) in 
relation to column AC (Party)

9. Open Analysis > Groups > Group options and check the box „Colors 
specified in the Color column of the Vertices worksheet“.
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10. Open Graph Options > Vertices and set Shape from Image to Disk.

11. Refresh Graph.

12. Save map to the file.
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6. PARTY NETWORK MAP

20https://nodexlgraphgallery.org/Pages/Graph.aspx?graphID=167788

Workflow

Step 1: Group by Party

Step 2: Automate

https://nodexlgraphgallery.org/Pages/Graph.aspx?graphID=167788


6. PARTY NETWORK MAP

1. Save the previous dataset to a new file.

2. Select Analysis > Groups > Group by Vertex attribute

3. Set the first column to Party and click OK (see on the right).

4. Import the previously used automation file and then open 
the Automate window.

5. (!) Do not Group by cluster (see on the right).

6. Click Run and wait.
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1. Assign party colors to the groups in 
column B (Vertex Color).

2. Refresh the Graph.
3. Save the map to your file.



7. PARTY INTERACTION MAP
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Workflow

Step 1: Create new network

Step 2: Add images

Step 3: Customize map



7. PARTY INTERACTION MAP – CREATE NEW NETWORK
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1. Open a new NodeXL Pro workbook 
and save it to your machine.

2. Go to the Group Edges worksheet of 
the previous dataset.

3. Copy and paste columns Group 1 (A) 
and Group 2 (B) into columns Vertex 
1 (A) and Vertex 2 (B) of the Edges 
worksheet of the new workbook.

4. Also copy and paste the Edges 
column (C) into column N of the 
new workbook. This column will be 
used as edge weight.

5. Go to Data > Prepare Data > Get 
Vertices from Edges worksheet

6. Show Graph.

New workbook



7. PARTY INTERACTION MAP - CUSTOMIZE
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1. To add images to the map, go 
to the Twitter page of each 
party and copy the URL of the 
Twitter profile image to 
column F (Image File) in the 
Vertices spreadsheet.

2. Set the Graph Layout to Circle. 

3. Open Autofill columns to set 
Edge Color, Edge Width and 
Edge Opacity to Edges.

4. Save the map to your file.



8. MORE NETWORK ANALYSES
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There are many further ways to explore political networks with NodeXL Pro:

NodeXL Pro Twitter Users Network Importer

▪ Create single datasets for each party to explore inner-party networks. Increase 
the number of tweets to be collected and expand the time frame. 

NodeXL Pro Twitter Search Network Importer

▪ Make use of the NodeXL Pro Twitter Search Network Importer to analyze current 
discussions involving the politicians Twitter handles or names. Query example: 
@HeikoMaas OR "Heiko Maas" 

▪ Explore current discussions around hashtags e.g. #Bundestag or #Generaldebatte

Facebook Fan Pages Importer

▪ Almost all politicians have a Facebook Fan Page. Create a seed list with Facebook 
Fan Page IDs and use the NodeXL Pro Facebook Fan Pages Importer to explore 
page-to-page networks based on Fan Page Likes.

https://nodexlgraphgallery.org/Pages/Graph.aspx?graphID=167781
https://nodexlgraphgallery.org/Pages/Graph.aspx?graphID=167779
https://nodexlgraphgallery.org/Pages/Graph.aspx?graphID=167642
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If you have any questions or suggestions regarding this tutorial, 
please send an email to: 

info@smrfoundation.org

mailto:info@smrfoundation.org

